设为首页收藏本站

临官易

 找回密码
 立即注册

QQ登录

只需一步,快速开始

临官易 算命占卜 算法面试 查看内容

杨百万技术指标百万踏浪源码(大智慧版)

2015-4-5 14:50| 发布者: 道无边际| 查看: 1958| 评论: 0

摘要: 百万踏浪采用5周期RSI和SlowKDJ中K线和D线的金叉和死叉来综合给出买入卖出信号,是杨百万老师技术指标中经典的经典。 {百万踏浪}{副图}{大智慧L2公式}a1:=REF(C,1);标尺:((SMA((MAX((C - a1),0)),5,1)) / (SMA(ABS(( ...

百万踏浪采用5周期RSI和SlowKDJ中K线和D线的金叉和死叉来综合给出买入卖出信号,是杨百万老师技术指标中经典的经典。

{百万踏浪}{副图}{大智慧L2公式}
a1:=REF(C,1);
标尺:((SMA((MAX((C - a1),0)),5,1)) / (SMA(ABS((C - a1)),5,1))) * 100,linethick2,colorGreen;
a2:=((C - (LLV(L,9))) / ((HHV(H,9)) - (LLV(L,9)))) * 100;
a3:=SMA(a2,3,1);
a4:=SMA(a3,3,1);
a5:=SMA(a4,2,1);
浪:(3 * a4) - (2 * a5),linethick2,colorMagenta;
波:(a4),linethick2,colorRed;
段:(a5),linethick2,colorYellow;
a6:=(CROSS(a3,a4)) AND (a4 < 25);
STICKLINE(a6,0,(a4 + 5),1,1),linethick4,colorMagenta;
a7:=(CROSS(a4,a5)) AND (a4 < 50);
a8:=(a7 AND (V > ((REF(V,1)) * 2))) AND (V > ((REF((MA(V,5)),1)) * 2));
STICKLINE(a7,0,(a4 + 5),1,1),linethick4,colorWhite;
DRAWTEXT((a7 AND ((COUNT(a7,8)) = 1)),(a4 - 8),'.-短抄'),colorWhite;
STICKLINE(a8,0,(a4 + 5),1,1),linethick4,colorRed;
DRAWTEXT((a8 AND ((COUNT(a8,8)) = 1)),(a4 - 6),'放量'),linethick2,colorRed;
a9:=((CROSS(a3,a4)) AND (a4 > 80)) AND (a4 > a5);
STICKLINE((a9 AND ((COUNT(a9,5)) = 1)),(a4 - 5),100,1,1),linethick2,colorGreen;
a10:=(CROSS(a5,a4)) AND (a4 > 50);
STICKLINE(a10,(a4 - 5),100,1,1),linethick4,colorYellow;
DRAWTEXT((a10 AND ((COUNT(a10,8)) = 1)),(a4 + 16),'震荡'),colorYellow;
Y:(-2),linethick4,ColorFF0000;
B:(99),POINTDOT,linethick2,colorYellow;
T:(81),POINTDOT,linethick2,colorRed;
X:(15),POINTDOT,linethick2,colorGreen;
a11:=1 / WINNER(C);
a12:=MA(C,13);
a13:=100 - ABS((((C - a12) / a12) * 100));
a14:=LLV(L,75);
a15:=HHV(H,75);
a16:=(a15 - a14) / 100;
a17:=SMA(((C - a14) / a16),20,1);
a18:=SMA(((O - a14) / a16),20,1);
a19:=(3 * a17) - (2 * (SMA(a17,15,1)));
a20:=(3 * a18) - (2 * (SMA(a18,15,1)));
a21:=100 - a20;
a22:=100 - a19;
a23:=MA((WINNER((C * 0.95)) * 100),3);
a24:=100 - (IF((a11 > 5),(IF((a11 < 100),a11,(a13 - 10))),0));
a25:=a23 > a13;
a26:=(REF(L,1)) * 0.9;
a27:=L * 0.9;
a28:=((a27 * V) + (a26 * (CAPITAL - V))) / CAPITAL;
a29:=EMA(a28,30);
a30:=((SMA((MAX((C - a1),0)),7,1)) / (SMA(ABS((C - a1)),7,1))) * 100;
a31:=((SMA((MAX((C - a1),0)),13,1)) / (SMA(ABS((C - a1)),13,1))) * 100;
a32:=BARSCOUNT(C);
a33:=((SMA((MAX((C - a1),0)),6,1)) / (SMA(ABS((C - a1)),6,1))) * 100;
a34:=((-200 * ((HHV(H,60)) - C)) / ((HHV(H,60)) - (LLV(L,60)))) + 100;
a35:=((C - (LLV(L,15))) / ((HHV(H,15)) - (LLV(L,15)))) * 100;
a36:=SMA((((SMA(a35,4,1)) - 50) * 2),3,1);
a37:=((INDEXC - (LLV(INDEXL,14))) / ((HHV(INDEXH,14)) - (LLV(INDEXL,14)))) * 100;
a38:=SMA(a37,4,1);
a39:=SMA(a38,3,1);
a40:=(((HHV(H,30)) - C) / C) * 100;
a41:=((((((((a33 <= 25) AND (a34 < -95)) AND (a40 > 20)) AND (a36 < -30)) AND (a39 < 30)) AND ((a29 - C) >= -0.25)) AND (a30 < 22)) AND (a31 < 28)) AND (a32 > 50);
a42:=((H + L) + C) / 3;
a43:=(a42 - (MA(a42,14))) / (0.015 * (AVEDEV(a42,14)));
a44:=(a42 - (MA(a42,70))) / (0.015 * (AVEDEV(a42,70)));
a45:=IF(((((a43 >= 150) AND (a43 < 200)) AND (a44 >= 150)) AND (a44 < 200)),10,0);
a46:=IF(((((a43 <= -150) AND (a43 > -200)) AND (a44 <= -150)) AND (a44 > -200)),-10,a45);
a47:=(IF(((a44 >= 200) AND (a43 >= 150)),15,(IF(((a44 <= -200) AND (a43 <= -150)),-15,a46)))) + 50;
STICKLINE(a41,0,50,12,0);
DRAWTEXT(((CROSS(a41,0.5)) AND ((COUNT((a41 = 1),10)) = 1)),60,'百万导弹'),colorGreen;
a48:="KDJ.J#WEEK"(27,5,3);
a49:="KDJ.J#DAY"(27,5,3);
a50:=(13);
a51:=IF((a48 <= 13),30,0);
a52:=IF((CROSS(a48,a50)),60,0);
a53:=IF((a49 <= 10),45,0);
a54:=IF((CROSS(a49,a50)),70,0);
STICKLINE((a52 > 0),0,50,8,0),linethick2,colorRed;
买入信号:DRAWGBK((a51 > 0),STRIP(rgb(0,0,0),rgb(88,0,88),0)),colorRed;
a55:="SLOWKD.K#WEEK"(9,3,3,2);
a56:="SLOWKD.D#WEEK"(9,3,3,2);
满仓买入:(CROSS(a55,a56)) AND (a55 < 45),colorYellow;
抛股:(CROSS(a56,a55)) AND (a56 > 40),colorGreen;
STICKLINE(满仓买入,0,40,8,0),linethick2,colorYellow;
STICKLINE(抛股,100,80,8,0),linethick2,colorGreen;
DRAWTEXT(满仓买入,55,'...波段'),colorYellow;
DRAWTEXT(满仓买入,45,'..满仓买入'),colorYellow;
DRAWTEXT((a52 > 0),12,'-买入信号'),colorRed;
DRAWTEXT(抛股,76,'逃顶'),linethick2,colorGreen;
DRAWTEXT(抛股,66,'抛股'),linethick2,colorGreen;
YY:(0),linethick2;
HH:(90),POINTDOT,linethick2,colorRed;
{类型:技术指标->00.杨百万自用精典指标
注释:
百万趋势:灵魂精典指标。内含导弹,探庄。日周金叉死叉。
波段用周线,短线用日线。结合蚂蟥叮庄共振,效果极佳。
使用法则:
上下二线贴近起魈时为买点,远离死叉为卖点。
金叉时伴有大成交量为黑马,强势股二次死叉卖。          
多头市场:股价不跌指标下跌,强势整理,能创新高.          
空头市场:股价不涨指标上行,弱势整理,要创新低。
成交量不活跃的个股不参考,除权股空头市场不参考。
短线用日线,中线波段用周线,日周共振底部区域。
日、周、月三线划一,后势涨势较猛是黑马股。
姓名:杨怀定(杨百万),
电话:13122660278
电邮:YANGHD@SH163.NET,
}
{无}
{------------------  ------------------};

鲜花

握手

雷人

路过

鸡蛋
返回顶部