设为首页收藏本站

临官易

 找回密码
 立即注册

QQ登录

只需一步,快速开始

临官易 算命占卜 算法面试 查看内容

杨百万技术指标百万踏浪源码(通达信版)

2015-4-5 15:10| 发布者: 道无边际| 查看: 1993| 评论: 0

摘要: 根据杨百万老师大智慧版的百万踏浪改编,可以在通达信上运行。其中百万踏浪引用了公式SlowKDJ,需要用户自己输入。A1:=REF(C,1);RSI5:((SMA((MAX((C - A1),0)),5,1)) / (SMA(ABS((C - A1)),5,1))) * 100,LINETHICK2, ...
根据杨百万老师大智慧版的百万踏浪改编,可以在通达信上运行。其中百万踏浪引用了公式SlowKDJ,需要用户自己输入。
SlowKDJ:


百万踏浪:

A1:=REF(C,1);
RSI5:((SMA((MAX((C - A1),0)),5,1)) / (SMA(ABS((C - A1)),5,1))) * 100,LINETHICK2,COLORGREEN;
A3:="SLOWKDJ.FASTK"(9,3,3,2);
A4:="SLOWKDJ.K"(9,3,3,2);
A5:="SLOWKDJ.D"(9,3,3,2);
A2:="SLOWKDJ.J"(9,3,3,2);
J:(A2),LINETHICK1,COLORMAGENTA;
K:(A4),LINETHICK2,COLORRED;
D:(A5),LINETHICK1,COLORYELLOW;
A6:=(CROSS(A3,A4)) AND (A4 < 25);
STICKLINE(A6,0,(A4 + 5),1,1),LINETHICK4,COLORMAGENTA;
A7:=(CROSS(A4,A5)) AND (A4 < 50);
A8:=(A7 AND (V > ((REF(V,1)) * 2))) AND (V > ((REF((MA(V,5)),1)) * 2));
STICKLINE(A7,0,(A4 + 5),1,1),LINETHICK4,COLORWHITE;
DRAWTEXT((A7 AND ((COUNT(A7,8)) = 1)),(A4 - 8),'.-短抄'),COLORWHITE;
STICKLINE(A8,0,(A4 + 5),1,1),LINETHICK4,COLORRED;
DRAWTEXT((A8 AND ((COUNT(A8,8)) = 1)),(A4 - 6),'放量'),LINETHICK2,COLORRED;
A9:=((CROSS(A3,A4)) AND (A4 > 80)) AND (A4 > A5);
STICKLINE((A9 AND ((COUNT(A9,5)) = 1)),(A4 - 5),100,1,1),LINETHICK2,COLORGREEN;
A10:=(CROSS(A5,A4)) AND (A4 > 50);
STICKLINE(A10,(A4 - 5),100,1,1),LINETHICK4,COLORYELLOW;
DRAWTEXT((A10 AND ((COUNT(A10,8)) = 1)),(A4 + 16),'震荡'),COLORYELLOW;
Y:(-2),LINETHICK4,COLORFF0000;
B:(99),LINETHICK2,COLOR2233EE;
T:(81),LINETHICK1,COLORRED;
X:(15),LINETHICK1,COLORGREEN;
YY:(0),LINETHICK2;
HH:(90),POINTDOT,LINETHICK2,COLORRED;
A11:=1 / WINNER(C);
A12:=MA(C,13);
A13:=100 - ABS((((C - A12) / A12) * 100));
A14:=LLV(L,75);
A15:=HHV(H,75);
A16:=(A15 - A14) / 100;
A17:=SMA(((C - A14) / A16),20,1);
A18:=SMA(((O - A14) / A16),20,1);
A19:=(3 * A17) - (2 * (SMA(A17,15,1)));
A20:=(3 * A18) - (2 * (SMA(A18,15,1)));
A21:=100 - A20;
A22:=100 - A19;
A23:=MA((WINNER((C * 0.95)) * 100),3);
A24:=100 - (IF((A11 > 5),(IF((A11 < 100),A11,(A13 - 10))),0));
A25:=A23 > A13;
A26:=(REF(L,1)) * 0.9;
A27:=L * 0.9;
A28:=((A27 * V) + (A26 * (CAPITAL - V))) / CAPITAL;
A29:=EMA(A28,30);
A30:=((SMA((MAX((C - A1),0)),7,1)) / (SMA(ABS((C - A1)),7,1))) * 100;
A31:=((SMA((MAX((C - A1),0)),13,1)) / (SMA(ABS((C - A1)),13,1))) * 100;
A32:=BARSCOUNT(C);
A33:=((SMA((MAX((C - A1),0)),6,1)) / (SMA(ABS((C - A1)),6,1))) * 100;
A34:=((-200 * ((HHV(H,60)) - C)) / ((HHV(H,60)) - (LLV(L,60)))) + 100;
A35:=((C - (LLV(L,15))) / ((HHV(H,15)) - (LLV(L,15)))) * 100;
A36:=SMA((((SMA(A35,4,1)) - 50) * 2),3,1);
A37:=((INDEXC - (LLV(INDEXL,14))) / ((HHV(INDEXH,14)) - (LLV(INDEXL,14)))) * 100;
A38:=SMA(A37,4,1);
A39:=SMA(A38,3,1);
A40:=(((HHV(H,30)) - C) / C) * 100;
A41:=((((((((A33 <= 25) AND (A34 < -95)) AND (A40 > 20)) AND (A36 < -30)) AND (A39 < 30)) AND ((A29 - C) >= -0.25)) AND (A30 < 22)) AND (A31 < 28)) AND (A32 > 50);
A42:=((H + L) + C) / 3;
A43:=(A42 - (MA(A42,14))) / (0.015 * (AVEDEV(A42,14)));
A44:=(A42 - (MA(A42,70))) / (0.015 * (AVEDEV(A42,70)));
A45:=IF(((((A43 >= 150) AND (A43 < 200)) AND (A44 >= 150)) AND (A44 < 200)),10,0);
A46:=IF(((((A43 <= -150) AND (A43 > -200)) AND (A44 <= -150)) AND (A44 > -200)),-10,A45);
A47:=(IF(((A44 >= 200) AND (A43 >= 150)),15,(IF(((A44 <= -200) AND (A43 <= -150)),-15,A46)))) + 50;
STICKLINE(A41,0,50,12,0);
DRAWTEXT(((CROSS(A41,0.5)) AND ((COUNT((A41 = 1),10)) = 1)),60,'百万导弹'),COLORGREEN;
A48:="KDJ.J#WEEK"(27,5,3);
A49:="KDJ.J#DAY"(27,5,3);
A50:=(13);
A51:=IF((A48 <= 13),30,0);
A52:=IF((CROSS(A48,A50)),60,0);
A53:=IF((A49 <= 10),45,0);
A54:=IF((CROSS(A49,A50)),70,0);
STICKLINE((A52 > 0),0,50,8,0),LINETHICK2,COLORRED;
A55:="SLOWKDJ.K#WEEK"(9,3,3,2);
A56:="SLOWKDJ.D#WEEK"(9,3,3,2);
满仓买入:(CROSS(A55,A56)) AND (A55 < 45),COLORYELLOW;
抛股:(CROSS(A56,A55)) AND (A56 > 40),COLORGREEN;
STICKLINE(满仓买入,0,40,8,0),LINETHICK2,COLORYELLOW;
STICKLINE(抛股,100,80,8,0),LINETHICK2,COLORGREEN;
DRAWTEXT(满仓买入,55,'...波段'),COLORYELLOW;
DRAWTEXT(满仓买入,45,'..满仓买入'),COLORYELLOW;
DRAWTEXT((A52 > 0),12,'-买入信号'),COLORRED;
DRAWTEXT(抛股,76,'逃顶'),LINETHICK2,COLORGREEN;
DRAWTEXT(抛股,66,'抛股'),LINETHICK2,COLORGREEN;

下面给出一个运行实例:


鲜花

握手

雷人

路过

鸡蛋
返回顶部